« 

Wenn, dann, sonst (Excel)

 

Kennt sich jemand aus?
Ich möchte in Excel mit einer Wenn-Funkion arbeiten. Nur... hab ich in meiner Tabelle nicht nur Zahlen, sondern manche Artikel sind mit xx (=nicht vorhanden) gekennzeichnet.

Jetzt bräuchte ich ja hierfür die Wenn-Funktion.
Mein Gedankengang (meine Formel) ist folgender:

WennC2=xx;dannxx_sonstC2+D3 (oder so ähnlich)

Aber mit den xx nach dem Gleichheitszeichen bringt mir Excel ganz einfach eine Fehlermeldung... :/

Fehlt mir da noch ein Zeichen?
Oder kann man in einer Wenn-Funktion grundsätzlich keine Zahlen und Texte mischen?

...wär ja schon blöd...

Danke!!

Grüßle ff



Video: Filmstart 'Kokowääh 2': "Wenn man sich trennt, dann ist es vorbei!"

  • Filmstart 'Kokowääh 2': "Wenn man sich trennt, dann ist es vorbei!"
  • Neu im Kino: Ein Fehltritt mit katastrophalen Folgen in 'No Turning Back'
  • Selbstgemacht! Eine ipad-Hülle mit der 'Tunesisch Häkeln'-Methode
 

Ups...

...doch noch Antworten

Okay, danke! ...uch für die Info mit der "Hilfe". Das hab ich na klar zuvor schon mal überflogen

ABER... ich hab doch noch selbst rausgefunden, wo mein Fehler lag.

Nämlich: die Zellen mit "xx" als Text formatieren und die "xx" in nicht in einfache xx` setzen, wie Excel selbst vorschlägt!! Mensch... eigentlich voll easy. Der Rest meiner Formel hat nämlich soweit gestimmt...

Außerdem hab ich mich durch die Meldung FALSCH irritieren lassen... blöööööd... nicht?!

Grüßle ff


 

=WENN(c2="xx";"xx";C2+D3)

so gets...
=WENN(c2="xx";"xx";C2+D3)


 

...

ich sag das nur ungern, aber auch exel hat eine hilfe in der man die syntax aller funktionen und befehle nachschlagen kann. lesen macht schlau


 

Super

von:batmax1

Du ja ein schlauer...;-(


 

Vielleicht hilfts...

von:louiscyphre

WENN

Siehe auch

Gibt eine Wahrheitsprüfung an, die durchgeführt werden soll.

Verwenden Sie die WENN-Funktion, um bedingte Tests an Werten und Formeln auszuführen.

Syntax

WENN(Prüfung;Dann_Wert;Sonst_Wert)

Prüfung ist ein beliebiger Wert oder Ausdruck, der WAHR oder FALSCH sein kann. Beispielsweise ist A10=100 ein logischer Ausdruck; wenn der Wert in einer Zelle A10 gleich 100 ist, ist der Ausdruck WAHR. Andernfalls ist der Ausdruck FALSCH. Dieses Argument kann einen beliebigen Vergleichsberechnungsoperator verwenden.

Dann_Wert ist der Wert, der zurückgegeben wird, wenn Prüfung WAHR ist. Wenn dieses Argument beispielsweise die Zeichenfolge "Im Budget" ist und das Argument Prüfung als WAHR ausgewertet wird, zeigt die WENN-Funktion den Text "Im Budget" an. Wenn Prüfung WAHR und Dann_Wert leer ist, gibt dieses Argument 0 (Null) zurück. Um das Wort WAHR anzuzeigen, verwenden Sie für dieses Argument den Wahrheitswert WAHR. Dann_Wert kann eine andere Formel sein.

Sonst_Wert ist der Wert, der zurückgegeben wird, wenn Prüfung FALSCH ist. Wenn es sich bei diesem Argument beispielsweise um die Zeichenfolge "Budget überschritten" handelt und das Argument Prüfung als FALSCH ausgewertet wird, zeigt die WENN-Funktion den Text "Budget überschritten" an. Wenn Prüfung FALSCH ist und Sonst_Wert nicht angegeben wird (d.h. auf Dann_Wert folgt kein Semikolon), wird der Wahrheitswert FALSCH zurückgegeben. Wenn Prüfung FALSCH und Sonst_Wert leer ist (d.h. auf Dann_Wert folgt ein Semikolon und eine schließende Klammer), wird der Wert 0 (Null) zurückgegeben. Sonst_Wert kann eine andere Formel sein.

Hinweise

Damit es möglich ist, kompliziertere Bedingungen zu formulieren, können bis zu sieben WENN-Funktionen als Dann_Wert- und Sonst_Wert-Argumente geschachtelt werden. Vergleichen Sie dazu das letzte der folgenden Beispiele.
Sobald die beiden Argumente Dann_Wert und Sonst_Wert ausgewertet sind, gibt WENN den Wert zurück, den diese Anweisungen zurückgeben.
Ist eines der an eine WENN-Funktion übergebenen Argumente eine Matrix, wird bei der Ausführung dieser WENN-Anweisung jedes Element der Matrix ausgewertet.
Microsoft Excel stellt weitere Funktionen zur Verfügung, die es Ihnen ermöglichen, Ihre Daten auf der Grundlage einer Bedingung zu analysieren. Um beispielsweise die Anzahl von Vorkommen einer Zeichenfolge oder einer Zahl innerhalb eines Zellbereichs zu zählen, verwenden Sie die ZÄHLENWENN-Arbeitsblattfunktion. Um eine Summe auf der Grundlage einer Zeichenfolge oder einer Zahl innerhalb eines Zellbereichs zu ermitteln, verwenden Sie die SUMMEWENN-Arbeitsblattfunktion. Weitere Informationen finden Sie unter Berechnen eines Wertes auf der Grundlage einer Bedingung.
Beispiel 1

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

Wie wird's gemacht?

Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften.


Auswählen eines Beispiels aus der Hilfe

Drücken Sie STRG+C.
Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.

1
2
A
Daten
50
Formel Beschreibung (Ergebnis)
=WENN(A2<=100;"Im Budget";"Budget überschritten") Wenn die oben genannte Zahl kleiner gleich 100 ist, zeigt die Formel "Im Budget" an. Andernfalls wird "Budget überschritten" angezeigt. (Im Budget)
=WENN(A2=100;SUMME(B5:B15);"") Wenn die oben genannte Zahl gleich 100 ist, wird der Bereich B5:B15 berechnet. Andernfalls wird eine leere Zeichenfolge ("") zurückgegeben. ()


Beispiel 2

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

Wie wird's gemacht?

Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften.


Auswählen eines Beispiels aus der Hilfe

Drücken Sie STRG+C.
Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.

1
2
3
4
A B
Tatsächliche Kosten Geschätzte Kosten
1500 900
500 900
500 925
Formel Beschreibung (Ergebnis)
=WENN(A2>B2;"Budget überschritten";"OK") Überprüft, ob in der ersten Zeile das Budget überschritten ist (Budget überschritten)
=WENN(A3>B3;"Budget überschritten";"OK") Überprüft, ob in der zweiten Zeile das Budget überschritten ist (OK)


Beispiel 3

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

Wie wird's gemacht?

Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften.


Auswählen eines Beispiels aus der Hilfe

Drücken Sie STRG+C.
Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.

1
2
3
4
A
Punktzahl
45
90
78
Formel Beschreibung (Ergebnis)
=WENN(A2>89;"A";WENN(A2>79;"B"; WENN(A2>69;"C";WENN(A2>59;"D";"F")))) Weist der ersten Punktzahl eine Einstufung zu (F)
=WENN(A3>89;"A";WENN(A3>79;"B"; WENN(A3>69;"C";WENN(A3>59;"D";"F")))) Weist der zweiten Punktzahl eine Einstufung zu (A)
=WENN(A4>89;"A";WENN(A4>79;"B"; WENN(A4>69;"C";WENN(A4>59;"D";"F")))) Weist der dritten Punktzahl eine Einstufung zu (C)


In diesem Beispiel ist die zweite WENN-Anweisung das Argument Sonst_Wert der ersten WENN-Anweisung. Ähnliches gilt für die dritte WENN-Anweisung, die das Argument Sonst_Wert der zweiten WENN-Anweisung ist. Ergibt beispielsweise die erste Prüfung (Durchschnitt>89) den Wert WAHR, wird "A" zurückgegeben. Ergibt die erste Prüfung den Wert FALSCH, wird die zweite WENN-Anweisung ausgeführt usw.

Die Einstufungen werden Zahlen mithilfe des folgenden Schlüssels zugewiesen.

Einstufung Rückgabe
Größer als 89 A
80 bis 89 B
70 bis 79 C
60 bis 69 D
Kleiner als 60 F


 

Sieh mal ...

von:scaalp

es scheint doch leute zu geben, die die exel hilfe finden... es ist also bewiesenermaßen nicht unmöglich. sollte dir das zu denken geben .... ?

rtfm! - read the manual first - nicht wahr?!


« 
Seitenanfang

Liste der 10 vorhergehenden Diskussionen

Antworten Letzt. Beit.
  Samsun SGH E 330 entsperren
von:ingridmausi100
1
 
von:yasso88
0
  Homepage erstellen - frontpage??
von:girl1411
2
  Wanted: spezielles Programm
von:cadence4
1
  Besuchte Internetseiten wieder finden?
von:nicki7804
1
  Fernsehen im Internet!
von:verun4ik
1
  Notebook??
von:talona
6
  Wav in mp3 umwandeln
von:girl1411
2
  Mp3 player spielt plötzlich nur noch wma`s ab
von:hotlady1
1
  Kostenloasen iPod? Ja, durch Werbung
von:cyp4
3
Siehe auch Alle Diskussionen - Best-of - Auswahl